Back to overview
Resolved
Dashboard briefly unavailable
Jun 26, 2026 at 12:19pm UTC
Affected services
Dashboard
Resolved
Jun 26, 2026 at 12:19pm UTC
A DNS resolution issue caused a brief outage affecting the Dashboard. The issue was resolved within a couple minutes, and the Dashboard is now fully operational. No customer-facing review pages or API services were affected.
Affected services